How to configure Servers(DHCP, DNS, HTTP) along with the routers.


This article is all about how to configure Servers(DHCP, DNS, HTTP) along with the routers. In the previous post, we learn about how to configure DHCP, DNS, HTTP servers in Cisco packet tracers along with the switches. But configure servers along with switches is quite easy in the comparison of configuring servers along with routers. Because along with switches servers and routers are on the same network but here in this configuration servers and users are on the different networks. Like mail server servers are present in the company but the users are present worldwide and they are able to access those servers from anywhere in the world. So here in this lab, we learn about how to configure Servers along with the switches.

In this lab, we take two routers, two switches, two servers one is HTTP and another is DNS, two PCs, and connecting wires. Now take one of the routers and connect it with servers and then from another router we connect PCs as the figure is given below.

how to configure Servers along with routers

We do this whole lab in two parts. In the first part, we configure routers by assigning IP addresses to all the interfaces and configure static routing on both of the routers. In the second part, we configure both of the servers and assign IP address on PCs using static routing. So let’s start here how to configure this whole lab in two parts.

PART 1: – Configuring routers

1.  Assign IP address on all the interfaces of both the routers

For router R1

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

 

R1(config)#interface FastEthernet0/1

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

R1(config-if)#exit

 

For router R2

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 2.0.0.2 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

R2(config)#interface FastEthernet0/1

R2(config-if)#ip address 3.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R2(config-if)#exit

 

2.  Configure static routing on both the routers using given below command

For router R1

R1(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2

 

For router R2

R2(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1

 

Part 2: – Configure both of the Servers and assign IP address on both the PCs using static method

First of all, configure DNS server by going into the DNS service configuration figure is given below

how to configure DNS server

Also, remember that provide name and IP address of the HTTP server in the DNS server as given in the figure above.

Now configure HTTP server by going into the HTTP server configuration as the figure is shown below

how to configure http servers

Also, remember that give IP address of the DNS server at the time of assigning IP on the HTTP server.

After that assign, IP address on both of the PCs using static method figure is shown below

 

How to assign IP address on the PCs

Now to check configuration using both of the PCs use ping command on routers

                                                                       THAT’S IT

This is the whole process by which we can learn about how to configure servers along with the routers. By using this process we can easily understand this configuration. I think this article is helpful for you. If you have any queries regarding this then simply solved out through the comment section. Also, provide feedback to us because your feedback is valuable for us. Subscribe and follow our blog for further updates.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s