Understand how to configure backup route on cisco routers


This article is all about how to configure a backup route on cisco routers. In this tutorial, we learn about how to configure a backup route on routers, why we use a backup route, where we use a backup route and features of a backup route. We generally use a backup route in companies because the backup router allows the routing device to install a backup route to the management network before the routing protocol process is up and running. If somehow a router’s dynamic protocol gets a problem, it’s a good idea to have a backup route.

That way even when the dynamic protocol messes up, the router will still be functioning. We configure a backup routing easily on a router by changing its administrative value. default administrative value will be given below in the following table with routing protocols.

Routing Protocol Administartive Distance
Directly connected interface      0
Static route      1
EIGRP Summary      5
External Border Gateway Protocol (BGP)      20
Internal EIGRP      90
IGRP      100
OSPF      110
Intermediate System-to-Intermediate System (IS-IS)      115
Routing Information Protocol (RIP)      120
Exterior Gateway Protocol (EGP)      140
On-Demand Routing      160
External EIGRP      170
Internal BGP      200
Unknown      255

A lower administrative distance is preferred over a high distance and a routing source with an administrative distance is never used. So let’s start here how to configure a backup route on a cisco router.

Now to understand this process we take a lab in cisco packet tracer. In this lab, we take two routers having serial ports in it and two PCs.

how to configure backup route

We do this whole process in three parts in the first part we assign an IP address to all the interfaces of the router and in the second part, we configure a backup route on routers. In third part, we run troubleshooting commands on routers and verify your routing. So let’s start here how to configure a backup route on cisco routers.

part 1: – Assign IP address on all the interfaces of the router

For router R1

Router>enable

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 10.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface Serial0/0/0

R1(config-if)#ip address 20.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

R1(config-if)#exit

R1(config)#interface Serial0/0/1

R1(config-if)#ip address 30.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

R1(config-if)#exit

 

For router R2

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 40.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

R2(config)#interface Serial0/0/0

R2(config-if)#ip address 20.0.0.2 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R2(config-if)#exit

R2(config)#interface Serial0/0/1

R2(config-if)#ip address 30.0.0.2 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

R2(config-if)#exit

 

Part 2: – Configure static backup routing on routers

For router R1

R1(config)#ip route 40.0.0.0 255.0.0.0 20.0.0.2

R1(config)#ip route 40.0.0.0 255.0.0.0 30.0.0.2 10

 

For router R2

R2(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1

R2(config)#ip route 10.0.0.0 255.0.0.0 30.0.0.1 10

 

Part 3: – Run troubleshooting command on both the routers and verify our routing

For router R1

R1#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

    • candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet0/0

C 20.0.0.0/8 is directly connected, Serial0/0/0

C 30.0.0.0/8 is directly connected, Serial0/0/1

S 40.0.0.0/8 [1/0] via 20.0.0.2

 

For router R2

R2#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

    • candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is not set

S 10.0.0.0/8 [1/0] via 20.0.0.1

C 20.0.0.0/8 is directly connected, Serial0/0/0

C 30.0.0.0/8 is directly connected, Serial0/0/1

C 40.0.0.0/8 is directly connected, FastEthernet0/0

 

Now take one of the PC and use ping and tracert command to check whether they are communicate with each other or not

Packet Tracer PC Command Line 1.0

 

PC>ping 40.0.0.2

Pinging 40.0.0.2 with 32 bytes of data:

Reply from 40.0.0.2: bytes=32 time=8ms TTL=126

Reply from 40.0.0.2: bytes=32 time=1ms TTL=126

Reply from 40.0.0.2: bytes=32 time=1ms TTL=126

Reply from 40.0.0.2: bytes=32 time=1ms TTL=126

Ping statistics for 40.0.0.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 1ms, Maximum = 8ms, Average = 2ms

 

PC>tracert 40.0.0.2

Tracing route to 40.0.0.2 over a maximum of 30 hops:

1 0 ms 0 ms 0 ms 10.0.0.1

2 0 ms 2 ms 0 ms 20.0.0.2

3 1 ms 1 ms 0 ms 40.0.0.2

Trace complete.

THAT’S IT

This is the whole process for configuring a static backup route on a router. If you have any queries regarding this feel free to ask through the comment section and also provide feedback to us because your feedback is valuable for us.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s