How to configure null routing on cisco routers


This article is all about how to configure null routing on cisco routers in cisco packet tracer. In other words, null o routing is also known as black hole routing configuration over the cisco routers. In computer networking, a null route or black hole route is a network route that goes nowhere. Matching packets are dropped (ignored) rather than forwarded, acting as a kind of very limited firewall. Null routing is acting as a black hole on the routers because it sends unwanted packets from a certain network to black hole without reaching them to the receiver. it diverts all the packets to the black hole from where it never come back again. It is a type of trash or Recycles Bin for route packets. Basically, companies used this to drop some specific network to stop the DDOS attack. All the traffic from an unwanted network is sent to the null interface is discarded. Network admin used it to discard traffic simply by routing it to the null interface.

Now here we take a lab in cisco packet tracer to understand null routing or black hole routing easily.

null routing configuration

In this lab, we take three routers and three PCs. Here Pcs are used to check null routing on your system. First of all, we assign IP address on all the interfaces of the routers and after that, we configure null routing to a certain router to stop DDOS attacks and divert heavy unwanted traffic into a black hole. After that, we assign IP address in the PCs using static method and check whether null routing is work properly or not on the routers. Like here in this tutorial I am going to block packets generated from router R2 4.0.0.o network for 8.0.0.0 network.

Now, first of all, we assign the IP address to all the interfaces of the routers and up all the routers using no shut command.

For router R1

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: NO

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface Serial0/0/0

R1(config-if)#no ip address

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

R1(config-if)#exit

R1(config)#interface Serial0/0/1

R1(config-if)#ip address 3.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

R1(config-if)#exit

 

For router R2

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 4.0.0.1 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

R2(config)#interface Serial0/0/0

R2(config-if)#ip address 2.0.0.2 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R2(config-if)#exit

R2(config)#interface Serial0/0/1

R2(config)#ip address 5.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

R2(config-if)#exit

 

For router R3

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R3

R3(config)#interface FastEthernet0/0

R3(config-if)#ip address 6.0.0.1 255.0.0.0

R3(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R3(config-if)#exit

R3(config)#interface Serial0/0/0

R3(config-if)#ip address 7.0.0.1 255.0.0.0

R3(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

R3(config-if)#exit

R3(config)#interface Serial0/0/1

R3(config-if)#ip address 5.0.0.2 255.0.0.0

R3(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

R3(config-if)#exit

 

For router R4

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R4

R4(config)#interface FastEthernet0/0

R4(config-if)#ip address 8.0.0.1 255.0.0.0

R4(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R4(config-if)#exit

R4(config)#interface Serial0/0/0

R4(config-if)#ip address 7.0.0.2 255.0.0.0

R4(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R4(config-if)#exit

R4(config)#interface Serial0/0/1

R4(config-if)#ip address 3.0.0.2 255.0.0.0

R4(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

R4(config-if)#exit

 

Now we configure routing on the routers in the given below manner on the routers

For router R1

R1(config)#ip route 4.0.0.0 255.0.0.0 2.0.0.2

R1(config)#ip route 5.0.0.0 255.0.0.0 2.0.0.2

R1(config)#ip route 6.0.0.0 255.0.0.0 5.0.0.2

R1(config)#ip route 8.0.0.0 255.0.0.0 3.0.0.2

R1(config)#ip route 7.0.0.0 255.0.0.0 3.0.0.2

 

For router R2

R2(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1

R2(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.1

R2(config)#ip route 6.0.0.0 255.0.0.0 5.0.0.2

R2(config)#ip route 8.0.0.0 255.0.0.0 3.0.0.2

R2(config)#ip route 7.0.0.0 255.0.0.0 null0

 

For router R3

R3(config)#ip route 4.0.0.0 255.0.0.0 5.0.0.1

R3(config)#ip route 2.0.0.0 255.0.0.0 5.0.0.1

R3(config)#ip route 8.0.0.0 255.0.0.0 7.0.0.2

R3(config)#ip route 3.0.0.0 255.0.0.0 7.0.0.2

R3(config)#ip route 1.0.0.0 255.0.0.0 3.0.0.1

 

For router R4

R4(config)#ip route 6.0.0.0 255.0.0.0 7.0.0.1

R4(config)#ip route 5.0.0.0 255.0.0.0 7.0.0.1

R4(config)#ip route 1.0.0.0 255.0.0.0 3.0.0.1

R4(config)#ip route 2.0.0.0 255.0.0.0 3.0.0.1

R4(config)#ip route 4.0.0.0 255.0.0.0 2.0.0.2

Now all the routers will be configured correctly usn null router. Now assign IP address to all the PCs to complete this lab and the use ping command on the PC which is directly connected through the router R2

 

Now check whether null routing is configured on the routers or not using the ping command, As the given below

Packet Tracer PC Command Line 1.0

PC>ping 8.0.0.2

Pinging 8.0.0.2 with 32 bytes of data:

Reply from 4.0.0.1: Destination host unreachable.

Reply from 4.0.0.1: Destination host unreachable.

Reply from 4.0.0.1: Destination host unreachable.

Reply from 4.0.0.1: Destination host unreachable.

Ping statistics for 8.0.0.2:

Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

                                   THAT’S IT

if this type of result will be shown on your screen that means your null routing configured successfully on the routers. If you have any queries regarding this simply solved out through the comment section and also provide feedback to us because your feedback is valuable for us.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s