How to configure a router as multiple DHCP server?


This article is all about how to configure multiple DHCP server on a single router. In this tutorial, we learn that how to configure a router then it acts as multiple DHCP server at a time. For the detailed explanation of this article, we take a lab in cisco packet tracer in which we configure more than one DHCP pool on a single router at a time and assign an IP address to the systems which connect through this router. After reading this article you will be able to configure more than one DHCP pool on a single router and also learn that how to configure a router as multiple DHCP server. In the previous lab, we also learned that how to configure a router as multiple DHCP server. Here we take an another Example of multiple DHCP server it is the little bit different from before so be careful.

Now here we take a lab in cisco packet tracer and configure routers as multiple DHCP server. In this lab, we take two routers and eight PCs and create two DHCP pool on a single router.

create multiple dhcp server on a single router

Let’s start here to make your router as multiple DHCP servers follow given below commands 

For router R1

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

 

R1(config)#interface FastEthernet0/1

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R1(config-if)#exit

 

R1(config)#interface Ethernet0/0/0

R1(config-if)#ip address 3.0.0.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

R1(config-if)#exit

These above commands are used for assign IP address to all the interfaces of the router and up all the interfaces of the router.

Now we use these given below commands to create DHCP pool on your router. If you want to create two or more than two DHCP pool on your router then choose different name for different pool as given below

R1(config)#ip dhcp pool rahul

R1(dhcp-config)#network 1.0.0.0 255.0.0.0

R1(dhcp-config)#default-router 1.0.0.1

R1(dhcp-config)#exit

 

R1(config)#ip dhcp pool mohit

R1(dhcp-config)#network 2.0.0.0 255.0.0.0

R1(dhcp-config)#default-router 2.0.0.1

R1(dhcp-config)#exit

Now DHCP pool will be created on your router R1 now given IPs to all your PCs which are directly connected to your router R1 by changing its IP configuration from static to DHCP.

For router R2

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 4.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

 

R2(config)#interface FastEthernet0/1

R2(config-if)#ip address 5.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R2(config-if)#exit

 

R2(config)#interface Ethernet0/0/0

R2(config-if)#ip address 3.0.0.2 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

R2(config-if)#exit

These commands are used for assign IP address and up all the interfaces of routers

Now for create DHCP pool on router use these commands on router R2

R2(config)#ip dhcp pool satish

R2(dhcp-config)#network 4.0.0.0 255.0.0.0

R2(dhcp-config)#default-router 4.0.0.1

R2(dhcp-config)#exit

 

R2(config)#ip dhcp pool hemendra

R2(dhcp-config)#network 5.0.0.0 255.0.0.0

R2(dhcp-config)#default-router 5.0.0.1

R2(dhcp-config)#exit

Now your router will be configured as DHCP server now give IPs to all the PCs which is connected to router R2 by changing its state from static to DHCP.

 

Now we troubleshoot our DHCP and verify configuration by given below commands

On router, R1 run this command to verify your configuration

R1>show ip dhcp binding

IP address Client-ID/ Lease expiration Type

Hardware address

1.0.0.2 0060.3EA0.4342 — Automatic

1.0.0.3 0001.96B7.392D — Automatic

2.0.0.2 0090.0C5E.535C — Automatic

2.0.0.3 0001.43EC.7435 — Automatic

 

On router, R2 run this command to verify your configuration

R2>show ip dhcp binding

IP address Client-ID/ Lease expiration Type

Hardware address

4.0.0.2 0007.ECDD.1857 — Automatic

4.0.0.3 000A.4188.919D — Automatic

5.0.0.2 0001.C98C.4088 — Automatic

5.0.0.3 0060.473D.D757 — Automatic

THAT’S IT

If you have any queries regarding this solved out through comment section.
If you want to saw this process in video format click on given below link or go to my youtube channel Technohelper24.com

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s