How to configure RIPv1 on Cisco routers along with serial port?


This tutorial is all about RIPv1 on cisco routers along with serial ports along with fast ethernet ports. In this article, we will learn about how to configure RIP routing on cisco routers. RIP routing on cisco routers along with serial ports is a little bit different from RIP routing along with fast ethernet ports. So, here I will explain to you how to configure RIPv1 routing on cisco routers along with serial ports using a lab in cisco packet tracer student. In this lab, we use three routers with serial ports to perform routing information protocol configuration. I have also mentioned all commands needed to troubleshoot RIP version 1.

Now here we will take a lab in cisco packet tracer and configure RIPv1 on all the routers. So, let’s start here.

rip routing with serial ports

We do this whole lab in three parts. In the first part, we assign an IP address to each and every interface of all the routers, set clock rates on router interface and up all the interfaces using no shut command. In the second part configure RIPv1 routing on each and every router and also assign an IP address to all the PCs. Now in the third part, we troubleshoot RIP routing on any router which is taken in the lab. So, let’s start here

Let’s begin with first part

For router R1

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface Serial0/0/0

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

R1(config-if)#exit

R1(config)#interface Serial0/0/1

R1(config-if)#ip address 6.0.0.2 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

R1(config-if)#exit

 

For router R2

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 3.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

R2(config)#interface Serial0/0/0

R2(config-if)#ip address 2.0.0.2 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R2(config-if)#exit

R2(config)#interface Serial0/0/1

R2(config)#ip address 4.0.0.1 255.0.0.0

R2(config-if)#clock rate 64000

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

R2(config-if)#exit

 

For router R3

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R3

R3(config)#

R3(config)#interface FastEthernet0/0

R3(config-if)#ip address 5.0.0.1 255.0.0.0

R3(config-if)#no shutdown

R3(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R3(config-if)#exit

R3(config)#interface Serial0/0/0

R3(config-if)#ip address 4.0.0.2 255.0.0.0

R3(config-if)#no shutdown

R3(config-if)#

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R3(config-if)#exit

R3(config)#interface Serial0/0/1

R3(config-if)#ip address 6.0.0.1 255.0.0.0

R3(config-if)#no shutdown

R3(config-if)#

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

R3(config-if)#exit

 

Now start configuration part 2: – Configure RIPv1 routing on all the routers

For router R1

R1>enable

R1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#router rip

R1(config-router)#version 1

R1(config-router)#network 1.0.0.0

R1(config-router)#network 2.0.0.0

R1(config-router)#network 6.0.0.0

R1(config-router)#exit

 

For router R2

R2>enable

R2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R2(config)#router rip

R2(config-router)#version 1

R2(config-router)#network 2.0.0.0

R2(config-router)#network 3.0.0.0

R2(config-router)#network 4.0.0.0

R2(config-router)#exit

 

For router R3

R3>enable

R3#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R3(config)#router rip

R3(config-router)#version 1

R3(config-router)#network 4.0.0.0

R3(config-router)#network 5.0.0.0

R3(config-router)#network 6.0.0.0

R3(config-router)#exit

Now all the routers will be configured by RIPv1 routing now we give IP addresses to all the PCs and then go for the third part and check for troubleshooting.

 

Part 3: RIP troubleshooting commands and verify your configuration

Now we run troubleshoot commands on router R3 and verify our configuration

R3>enable

R3#show ip protocols

Routing Protocol is “rip

Sending updates every 30 seconds, next due in 6 seconds

Invalid after 180 seconds, hold down 180, flushed after 240

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Redistributing: rip

Default version control: send version 1, receive 1

Interface Send Recv Triggered RIP Key-chain

FastEthernet0/0 1 1

Serial0/0/1 1 1

Serial0/0/0 1 1

Automatic network summarization is in effect

Maximum path: 4

Routing for Networks:

4.0.0.0

5.0.0.0

6.0.0.0

Passive Interface(s):

Routing Information Sources:

Gateway Distance Last Update

6.0.0.2 120 00:00:03

4.0.0.1 120 00:00:01

Distance: (default is 120)

 

R3#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

    • candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is not set

R 1.0.0.0/8 [120/1] via 6.0.0.2, 00:00:24, Serial0/0/1

R 2.0.0.0/8 [120/1] via 4.0.0.1, 00:00:22, Serial0/0/0

[120/1] via 6.0.0.2, 00:00:24, Serial0/0/1

R 3.0.0.0/8 [120/1] via 4.0.0.1, 00:00:22, Serial0/0/0

C 4.0.0.0/8 is directly connected, Serial0/0/0

C 5.0.0.0/8 is directly connected, FastEthernet0/0

C 6.0.0.0/8 is directly connected, Serial0/0/1

 

R3#show ip rip database

1.0.0.0/8 auto-summary

1.0.0.0/8

[1] via 6.0.0.2, 00:00:18, Serial0/0/1

2.0.0.0/8 auto-summary

2.0.0.0/8

[1] via 4.0.0.1, 00:00:14, Serial0/0/0 [1] via 6.0.0.2, 00:00:18, Serial0/0/1

3.0.0.0/8 auto-summary

3.0.0.0/8

[1] via 4.0.0.1, 00:00:14, Serial0/0/0

4.0.0.0/8 auto-summary

4.0.0.0/8 directly connected, Serial0/0/0

5.0.0.0/8 auto-summary

5.0.0.0/8 directly connected, FastEthernet0/0

6.0.0.0/8 auto-summary

6.0.0.0/8 directly connected, Serial0/0/1

 

R3#show ip route rip

R 1.0.0.0/8 [120/1] via 6.0.0.2, 00:00:20, Serial0/0/1

R 2.0.0.0/8 [120/1] via 4.0.0.1, 00:00:11, Serial0/0/0

[120/1] via 6.0.0.2, 00:00:20, Serial0/0/1

R 3.0.0.0/8 [120/1] via 4.0.0.1, 00:00:11, Serial0/0/0

 

R3#show ip interface brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 5.0.0.1 YES manual up up

FastEthernet0/1 unassigned YES unset administratively down down

Serial0/0/0 4.0.0.2 YES manual up up

Serial0/0/1 6.0.0.1 YES manual up up

Serial0/1/0 unassigned YES unset administratively down down

Serial0/1/1 unassigned YES unset administratively down down

Vlan1 unassigned YES unset administratively down down

 

R3#show clock

*5:33:51.955 UTC Tue Mar 2 1993

 

R3#show protocols

Global values:

Internet Protocol routing is enabled

FastEthernet0/0 is up, line protocol is up

Internet address is 5.0.0.1/8

FastEthernet0/1 is administratively down, line protocol is down

Serial0/0/0 is up, line protocol is up

Internet address is 4.0.0.2/8

Serial0/0/1 is up, line protocol is up

Internet address is 6.0.0.1/8

Serial0/1/0 is administratively down, line protocol is down

Serial0/1/1 is administratively down, line protocol is down

Vlan1 is administratively down, line protocol is down

 

 THAT’S IT

If you have any queries comment below otherwise contact me. RIPv1 does not support subnetting so we do not use it where subnetting is required at that place, we configure RIPv2 on the router because RIPv2 is supported subnetting. If you want to know in deep about the RIPv2 wait for my next article.

One thought on “How to configure RIPv1 on Cisco routers along with serial port?

  1. It is perfect time to make some plans for the future and
    it’s time to be happy. I have read this post and if I may just
    I desire to recommend you few attention-grabbing things or tips.
    Perhaps you could write next articles relating to this article.
    I want to read more issues about it!

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s