How to configure RIP version 1 routing on Cisco routers?


This article is all about RIP version 1 routing on the cisco router. In this tutorial, we will learn that how to configure RIPv1 (Routing Information Protocol) over the cisco routers. RIP routing configuration is much easier than static routing configuration but static routing is more secure then RIP routing. Basically, in small companies, we always use RIP routing because it is much much easier than static routing but RIP routing only applicable on up to 15 routers in a series. If the number of routers is moe than 15 then RIP routing is not be configured on that routers. So here using one example I will explain how to configure routing information protocol step by step. This article helps you a lot in learning networking and it also helps you for preparing CCNA certification exam. Hence you can easily learn how to configure RIPv1 routing on a Cisco router using Cisco packet tracer. So, let’s start here 

Now we will take a lab in cisco packet tracer. In this lab, we take three routers to perform routing information protocol configuration lab. In this article, I have also mentioned all commands needed to troubleshoot rip.

ripv1 configuration

We do this whole lab in three parts. In the first part, we assign IP address to each and every interface of all the routers and up all the interfaces using no shut command. In the second part configure RIPv1 routing on each and every router and also assign IP address to all the PCs. Now in the third part, we troubleshoot RIP routing on any router which is taken in the lab. So, let’s start here

Let’s begin with first part

 For router R1

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface FastEthernet0/1

R1(config-if)#ip address 6.0.0.2 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

R1(config-if)#exit

R1(config)#interface Ethernet0/0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

R1(config-if)#exit

Now for router R2
— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface FastEthernet0/0
R2(config-if)#ip address 2.0.0.2 255.0.0.0
R2(config-if)#no shutdown

R2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit
R2(config)#interface FastEthernet0/1
R2(config-if)#ip address 4.0.0.1 255.0.0.0
R2(config-if)#no shutdown

R2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

R2(config-if)#exit
R2(config)#interface Ethernet0/0/0
R2(config-if)#ip address 3.0.0.1 255.0.0.0
R2(config-if)#no shutdown

R2(config-if)#
%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

R2(config-if)#exit

Now for router R3 

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R3

R3(config)#interface FastEthernet0/0

R3(config-if)#ip address 6.0.0.1 255.0.0.0

R3(config-if)#no shutdown

R3(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R3(config-if)#exit

R3(config)#interface FastEthernet0/1

R3(config-if)#ip address 4.0.0.2 255.0.0.0

R3(config-if)#no shutdown

R3(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R3(config-if)#exit

R3(config)#interface Ethernet0/0/0

R3(config-if)#ip address 5.0.0.1 255.0.0.0

R3(config-if)#no shutdown

R3(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

R3(config-if)#exit

Now IP assigned on each and every interface of router now we go to the second part in this part we configure RIPv1 routing on each router. RIPv1 routing do not support subnetting so we use RIPv2 routing for subnetting we will discuss RIPv2 later now we configure RIPv1 routing on all routers so let’s start here

 

Now start configuring part 2: – configure RIPv1 routing on each router

For router R1

R1>enable

R1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#router rip

R1(config-router)#version 1

R1(config-router)#network 2.0.0.0

R1(config-router)#network 1.0.0.0

R1(config-router)#network 6.0.0.0

R1(config-router)#exit

Now for router R2

R2>enable

R2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R2(config)#router rip

R2(config-router)#version 1

R2(config-router)#network 2.0.0.0

R2(config-router)#network 3.0.0.0

R2(config-router)#network 4.0.0.0

R2(config-router)#exit

Now for router R3

R3>enable

R3#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R3(config)#router rip

R3(config-router)#version 1

R3(config-router)#network 4.0.0.0

R3(config-router)#network 5.0.0.0

R3(config-router)#network 6.0.0.0

R3(config-router)#exit

Now RIPv1 routing will be configured on all routers. Now we will give IP addresses to all the PCs according to their network and then check that they are communicating with each other on RIPv1 routing or not then we go to the third part of the lab.

 

Part 3: – Troubleshooting commands for RIP routing

Now we run troubleshoot commands on router R1 and verify the configuration.

R1>enable

R1#show ip protocols

Routing Protocol is “rip

Sending updates every 30 seconds, next due in 24 seconds

Invalid after 180 seconds, hold down 180, flushed after 240

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Redistributing: rip

Default version control: send version 1, receive 1

Interface Send Recv Triggered RIP Key-chain

FastEthernet0/0 1 1

Ethernet0/0/0 1 1

FastEthernet0/1 1 1

Automatic network summarization is in effect

Maximum path: 4

Routing for Networks:

1.0.0.0

2.0.0.0

6.0.0.0

Passive Interface(s):

Routing Information Sources:

Gateway Distance Last Update

2.0.0.2 120 00:00:22

6.0.0.1 120 00:00:18

Distance: (default is 120)

 

R1#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

    • candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is not set

C 1.0.0.0/8 is directly connected, Ethernet0/0/0

C 2.0.0.0/8 is directly connected, FastEthernet0/0

R 3.0.0.0/8 [120/1] via 2.0.0.2, 00:00:25, FastEthernet0/0

R 4.0.0.0/8 [120/1] via 2.0.0.2, 00:00:25, FastEthernet0/0

[120/1] via 6.0.0.1, 00:00:25, FastEthernet0/1

R 5.0.0.0/8 [120/1] via 6.0.0.1, 00:00:25, FastEthernet0/1

C 6.0.0.0/8 is directly connected, FastEthernet0/1

 

R1#show ip rip database

1.0.0.0/8 auto-summary

1.0.0.0/8 directly connected, Ethernet0/0/0

2.0.0.0/8 auto-summary

2.0.0.0/8 directly connected, FastEthernet0/0

3.0.0.0/8 auto-summary

3.0.0.0/8

[1] via 2.0.0.2, 00:00:08, FastEthernet0/0

4.0.0.0/8 auto-summary

4.0.0.0/8

[1] via 2.0.0.2, 00:00:08, FastEthernet0/0 [1] via 6.0.0.1, 00:00:05, FastEthernet0/1

5.0.0.0/8 auto-summary

5.0.0.0/8

[1] via 6.0.0.1, 00:00:05, FastEthernet0/1

6.0.0.0/8 auto-summary

6.0.0.0/8 directly connected, FastEthernet0/1

 

R1#show ip route rip

R 3.0.0.0/8 [120/1] via 2.0.0.2, 00:00:04, FastEthernet0/0

R 4.0.0.0/8 [120/1] via 2.0.0.2, 00:00:04, FastEthernet0/0

[120/1] via 6.0.0.1, 00:00:03, FastEthernet0/1

R 5.0.0.0/8 [120/1] via 6.0.0.1, 00:00:03, FastEthernet0/1

 

R1#show ip interface brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 2.0.0.1 YES manual up up

FastEthernet0/1 6.0.0.2 YES manual up up

Ethernet0/0/0 1.0.0.1 YES manual up up

Ethernet0/1/0 unassigned YES unset administratively down down

Vlan1 unassigned YES unset administratively down down

 

R1#show clock

*0:51:13.666 UTC Mon Mar 1 1993

 

 

R1#show protocols

Global values:

Internet Protocol routing is enabled

FastEthernet0/0 is up, line protocol is up

Internet address is 2.0.0.1/8

FastEthernet0/1 is up, line protocol is up

Internet address is 6.0.0.2/8

Ethernet0/0/0 is up, line protocol is up

Internet address is 1.0.0.1/8

Ethernet0/1/0 is administratively down, line protocol is down

Vlan1 is administratively down, line protocol is down

THAT’S IT

Note: – Rip version 1 do not support authentication and subnetting. For this purpose, we always use RIP version 2 routing.

In this lab we use fast ethernet port to configure RIPv1 routing on routers in next tutorial we will use the serial port for configuring RIP routing. If you have any queries comment below

28 thoughts on “How to configure RIP version 1 routing on Cisco routers?

  1. Right here is the right site for everyone who really wants to find out about
    this topic. You know a whole lot its almost hard to argue with
    you (not that I really will need to…HaHa).
    You definitely put a fresh spin on a subject that’s been discussed for decades.
    Wonderful stuff, just great!

    Like

  2. Wonderful blog! I found it while searching on Yahoo News.
    Do you have any suggestions on how to get listed in Yahoo News?
    I’ve been trying for a while but I never seem to get there!
    Appreciate it

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s