How to configure a little complex static routing on routers having serial ports.


This tutorial is all about static routing on routers having serial ports. In previous posts, we learn that How to configure static routing on cisco router using serial portHow to configure static routing on two or more than two routers and we also learn that how to configure static routing on 4 routers. Now here we take an another example of static routing configuration on cisco routers having serial ports. But here I take a little complex example on static routing and configured them step by step. If you prepare for networking jobs and interviews this lab is very helpful to you in understand and configure static routing on routers having serial ports. In this lab I have also mentioned troubleshoot command for static routing.

Now we take a lab in cisco packet tracer and then configure static routing on routers having serial ports in it.

static routing configuration

we divide this whole lab into three parts in first part we assign IP address to all the interfaces of routers and set clock rate on all the routers. then in second part we will configure static routing on routers and also provide IP address to all the PCs which is taken in this lab. Now in last or third part we run troubleshoot commands on any router and verify configuration.

Let’s begin with first part

For router R1

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface Serial0/0/0

R1(config-if)#ip address 4.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

R1(config-if)#

R1(config-if)#exit

R1(config)#interface Serial0/0/1

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

R1(config-if)#

R1(config-if)#exit

R1(config)#interface Serial0/1/0

R1(config-if)#ip address 3.0.0.1 255.0.0.0

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down

R1(config-if)#exit

 

For router R2

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 7.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

R2(config)#interface Serial0/0/1

R2(config-if)#ip address 6.0.0.1 255.0.0.0

R2(config-if)#clock rate 64000

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

R2(config-if)#exit

R2(config)#interface Serial0/0/0

R2(config-if)#ip address 4.0.0.2 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R2(config-if)#exit

R2(config)#interface Serial0/1/0

R2(config-if)#ip address 5.0.0.1 255.0.0.0

R2(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down

R2(config-if)#exit

 

For router R3

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R3

R3(config)#interface FastEthernet0/0

R3(config-if)#ip address 9.0.0.1 255.0.0.0

R3(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R3(config-if)#exit

R3(config)#interface Serial0/0/0

R3(config-if)#ip address 6.0.0.2 255.0.0.0

R3(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R3(config-if)#exit

R3(config)#interface Serial0/0/1

R3(config-if)#ip address 8.0.0.1 255.0.0.0

R3(config-if)#clock rate 64000

R3(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

R3(config-if)#exit

R3(config)#interface Serial0/1/0

R3(config-if)#ip address 3.0.0.2 255.0.0.0

R3(config-if)#clock rate 64000

R3(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

R3(config-if)#exit

 

For router R4

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R4

R4(config)#interface FastEthernet0/0

R4(config-if)#ip address 10.0.0.1 255.0.0.0

R4(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R4(config-if)#exit

R4(config)#interface Serial0/0/0

R4(config-if)#ip address 2.0.0.2 255.0.0.0

R4(config-if)#no shutdown

R4(config-if)#

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R4(config-if)#exit

R4(config)#interface Serial0/0/1

R4(config-if)#ip address 8.0.0.2 255.0.0.0

R4(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

R4(config-if)#exit

R4(config)#interface Serial0/1/0

R4(config-if)#ip address 5.0.0.2 255.0.0.0

R4(config-if)#clock rate 64000

R4(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

R4(config-if)#exit

 

Part 2 static routing configuration on each router

For router R1

R1>enable

R1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#ip route 5.0.0.0 255.0.0.0 4.0.0.2

R1(config)#ip route 5.0.0.0 255.0.0.0 2.0.0.2

R1(config)#ip route 8.0.0.0 255.0.0.0 2.0.0.2

R1(config)#ip route 10.0.0.0 255.0.0.0 2.0.0.2

R1(config)#ip route 10.0.0.0 255.0.0.0 5.0.0.2

R1(config)#ip route 6.0.0.0 255.0.0.0 4.0.0.2

R1(config)#ip route 6.0.0.0 255.0.0.0 3.0.0.2

R1(config)#ip route 6.0.0.0 255.0.0.0 2.0.0.2

R1(config)#ip route 7.0.0.0 255.0.0.0 2.0.0.2

R1(config)#ip route 7.0.0.0 255.0.0.0 4.0.0.2

R1(config)#ip route 7.0.0.0 255.0.0.0 6.0.0.1

R1(config)#ip route 7.0.0.0 255.0.0.0 5.0.0.1

R1(config)#ip route 9.0.0.0 255.0.0.0 6.0.0.2

R1(config)#ip route 9.0.0.0 255.0.0.0 8.0.0.1

R1(config)#ip route 9.0.0.0 255.0.0.0 3.0.0.2

 

For router R2

R2>enable

R2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R2(config)#ip route 1.0.0.0 255.0.0.0 4.0.0.1

R2(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1

R2(config)#ip route 1.0.0.0 255.0.0.0 3.0.0.1

R2(config)#ip route 2.0.0.0 255.0.0.0 3.0.0.1

R2(config)#ip route 2.0.0.0 255.0.0.0 4.0.0.1

R2(config)#ip route 2.0.0.0 255.0.0.0 5.0.0.2

R2(config)#ip route 2.0.0.0 255.0.0.0 8.0.0.2

R2(config)#ip route 3.0.0.0 255.0.0.0 4.0.0.1

R2(config)#ip route 3.0.0.0 255.0.0.0 6.0.0.2

R2(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2

R2(config)#ip route 8.0.0.0 255.0.0.0 5.0.0.2

R2(config)#ip route 8.0.0.0 255.0.0.0 2.0.0.2

R2(config)#ip route 8.0.0.0 255.0.0.0 6.0.0.2

R2(config)#ip route 8.0.0.0 255.0.0.0 3.0.0.2

R2(config)#ip route 9.0.0.0 255.0.0.0 6.0.0.2

R2(config)#ip route 9.0.0.0 255.0.0.0 3.0.0.2

R2(config)#ip route 9.0.0.0 255.0.0.0 8.0.0.1

 

R2(config)#ip route 10.0.0.0 255.0.0.0 8.0.0.2

R2(config)#ip route 10.0.0.0 255.0.0.0 2.0.0.2

R2(config)#ip route 10.0.0.0 255.0.0.0 5.0.0.2

 

For router R3

R3>enable

R3#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R3(config)#ip route 1.0.0.0 255.0.0.0 4.0.0.1

R3(config)#ip route 1.0.0.0 255.0.0.0 3.0.0.1

R3(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1

R3(config)#ip route 2.0.0.0 255.0.0.0 4.0.0.1

R3(config)#ip route 2.0.0.0 255.0.0.0 3.0.0.1

R3(config)#ip route 2.0.0.0 255.0.0.0 8.0.0.2

R3(config)#ip route 4.0.0.0 255.0.0.0 3.0.0.1

R3(config)#ip route 4.0.0.0 255.0.0.0 6.0.0.1

R3(config)#ip route 4.0.0.0 255.0.0.0 2.0.0.1

R3(config)#ip route 4.0.0.0 255.0.0.0 5.0.0.1

R3(config)#ip route 5.0.0.0 255.0.0.0 6.0.0.1

R3(config)#ip route 5.0.0.0 255.0.0.0 8.0.0.2

R3(config)#ip route 5.0.0.0 255.0.0.0 2.0.0.2

R3(config)#ip route 5.0.0.0 255.0.0.0 4.0.0.2

R3(config)#ip route 7.0.0.0 255.0.0.0 4.0.0.2

R3(config)#ip route 7.0.0.0 255.0.0.0 6.0.0.1

R3(config)#ip route 7.0.0.0 255.0.0.0 5.0.0.1

R3(config)#ip route 10.0.0.0 255.0.0.0 5.0.0.2

R3(config)#ip route 10.0.0.0 255.0.0.0 8.0.0.2

R3(config)#ip route 10.0.0.0 255.0.0.0 2.0.0.2

 

For router R4

R4>enable

R4#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R4(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1

R4(config)#ip route 1.0.0.0 255.0.0.0 4.0.0.1

R4(config)#ip route 1.0.0.0 255.0.0.0 3.0.0.1

R4(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.1

R4(config)#ip route 3.0.0.0 255.0.0.0 8.0.0.1

R4(config)#ip route 3.0.0.0 255.0.0.0 4.0.0.1

R4(config)#ip route 3.0.0.0 255.0.0.0 6.0.0.2

R4(config)#ip route 4.0.0.0 255.0.0.0 2.0.0.1

R4(config)#ip route 4.0.0.0 255.0.0.0 5.0.0.1

R4(config)#ip route 4.0.0.0 255.0.0.0 6.0.0.1

R4(config)#ip route 4.0.0.0 255.0.0.0 3.0.0.1

R4(config)#ip route 6.0.0.0 255.0.0.0 8.0.0.1

R4(config)#ip route 6.0.0.0 255.0.0.0 5.0.0.1

R4(config)#ip route 6.0.0.0 255.0.0.0 3.0.0.2

R4(config)#ip route 6.0.0.0 255.0.0.0 4.0.0.2

R4(config)#ip route 7.0.0.0 255.0.0.0 4.0.0.2

 

R4(config)#ip route 7.0.0.0 255.0.0.0 5.0.0.1

 

R4(config)#ip route 7.0.0.0 255.0.0.0 6.0.0.1

R4(config)#ip route 9.0.0.0 255.0.0.0 3.0.0.2

R4(config)#ip route 9.0.0.0 255.0.0.0 8.0.0.1

R4(config)#ip route 9.0.0.0 255.0.0.0 6.0.0.2

Now your all routers are configured by static routing now assign IP address to all the PCs and the check them they are working properly or not.

 

Part 3: Run statc routing troubleshooting command

Now we take router R4 and run troubleshoot command for verify static routing on it.

R4>enable

R4#show run

Building configuration…

Current configuration : 1527 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname R4

!

!

!

!

!

!

!

!

no ip cef

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.0.0.1 255.0.0.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

ip address 2.0.0.2 255.0.0.0

!

interface Serial0/0/1

ip address 8.0.0.2 255.0.0.0

!

interface Serial0/1/0

ip address 5.0.0.2 255.0.0.0

clock rate 2000000

!

interface Serial0/1/1

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

ip classless

ip route 1.0.0.0 255.0.0.0 2.0.0.1

ip route 1.0.0.0 255.0.0.0 4.0.0.1

ip route 1.0.0.0 255.0.0.0 3.0.0.1

ip route 3.0.0.0 255.0.0.0 2.0.0.1

ip route 3.0.0.0 255.0.0.0 8.0.0.1

ip route 3.0.0.0 255.0.0.0 4.0.0.1

ip route 3.0.0.0 255.0.0.0 6.0.0.2

ip route 4.0.0.0 255.0.0.0 2.0.0.1

ip route 4.0.0.0 255.0.0.0 5.0.0.1

ip route 4.0.0.0 255.0.0.0 6.0.0.1

ip route 4.0.0.0 255.0.0.0 3.0.0.1

ip route 6.0.0.0 255.0.0.0 8.0.0.1

ip route 6.0.0.0 255.0.0.0 5.0.0.1

ip route 6.0.0.0 255.0.0.0 3.0.0.2

ip route 6.0.0.0 255.0.0.0 4.0.0.2

ip route 7.0.0.0 255.0.0.0 4.0.0.2

ip route 7.0.0.0 255.0.0.0 5.0.0.1

ip route 9.0.0.0 255.0.0.0 3.0.0.2

ip route 9.0.0.0 255.0.0.0 6.0.0.2

ip route 9.0.0.0 255.0.0.0 8.0.0.1

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

 

R4#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

* – candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is not set

S 1.0.0.0/8 [1/0] via 2.0.0.1

[1/0] via 3.0.0.1

[1/0] via 4.0.0.1

C 2.0.0.0/8 is directly connected, Serial0/0/0

S 3.0.0.0/8 [1/0] via 2.0.0.1

[1/0] via 8.0.0.1

[1/0] via 4.0.0.1

[1/0] via 6.0.0.2

S 4.0.0.0/8 [1/0] via 2.0.0.1

[1/0] via 5.0.0.1

[1/0] via 3.0.0.1

[1/0] via 6.0.0.1

C 5.0.0.0/8 is directly connected, Serial0/1/0

S 6.0.0.0/8 [1/0] via 8.0.0.1

[1/0] via 5.0.0.1

[1/0] via 3.0.0.2

[1/0] via 4.0.0.2

S 7.0.0.0/8 [1/0] via 4.0.0.2

[1/0] via 5.0.0.1

C 8.0.0.0/8 is directly connected, Serial0/0/1

S 9.0.0.0/8 [1/0] via 3.0.0.2

[1/0] via 6.0.0.2

[1/0] via 8.0.0.1

C 10.0.0.0/8 is directly connected, FastEthernet0/0

 

THAT’S IT

If you have any queries regarding this simply comment below.

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s