How to configure static routing on cisco router using serial port?


In the previous article we learn that how to configure static routing on cisco router using the fast ethernet port on the router but sometimes we use the serial port on the router and then we want to configure the router with static routing. In that case, we use this method for configuring static routing on the router. Static routing on the serial port is little bit different from static routing configuration on the router using fast ethernet port because now in serial ports we also assign clock rate on routers interface which will be DCE. In this tutorial, we learn about that how to configure static routing on the serial port using a basic lab in cisco packet tracer. Let’s start to configure static routing.

static routing on serial port

Now, first of all, we assign IP address on routers interfaces and both PC also and make them up using no shut command on routers.

I think you also know how to assign IP address on PC. So, I am going start configuration on routers. if you don’t know about how to assign IP address on PC read my previous articles on CCNA.

How to configure a router and how to connect two different network through router?

How to configure basic static routing on routers

Learn how to configure static routing on 4 routers?

Now configure router R1

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: n

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface Serial0/0/0

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

R1(config-if)#exit

 

Now configure router R2

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: n

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 3.0.0.1 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#exit

R2(config)#interface Serial0/0/0

R2(config-if)#ip address 2.0.0.2 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

R2(config-if)#exit

 

Now again go to router R1 and configure static routing on it

R1(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2

Now go to router R2 and configure static routing on it

R2(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1

 

Now I am here show you how to troubleshoot a static routing configured router

On R1 router we use this commands

R1#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

* – candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is not set

C 1.0.0.0/8 is directly connected, FastEthernet0/0

C 2.0.0.0/8 is directly connected, Serial0/0/0

S 3.0.0.0/8 [1/0] via 2.0.0.2

explanation of above results how to check by this command on the router.

In above output, C indicates that directly connected networks on the router. In this case network, 1.0.0.0 and 2.0.0.0 are directly connected to this router R1.

S indicates that indirectly connected networks on the router through static routing. In this case network, 3.0.0.0 is indirectly connected and staticly routed via 2.0.0.2 port address.

Now if you want to check these computers are communicate or not then go to command prompt pc0 and open command prompt then type this command.
Packet Tracer PC Command Line 1.0
PC>ping 3.0.0.2

Pinging 3.0.0.2 with 32 bytes of data:

Request timed out.
Reply from 3.0.0.2: bytes=32 time=3ms TTL=126
Reply from 3.0.0.2: bytes=32 time=3ms TTL=126
Reply from 3.0.0.2: bytes=32 time=1ms TTL=126

Ping statistics for 3.0.0.2:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 3ms, Average = 2ms

Now If this result will be displayed on your PC your computers surely communicate with each other. If you have any queries and suggestions regarding this comment or contact me directly I will be here to help you in any type of problem.

8 thoughts on “How to configure static routing on cisco router using serial port?”

  1. Woah! I’m really loving the template/theme of this
    website. It’s simple, yet effective. A lot of times it’s tough to get that
    “perfect balance” between usability and visual appearance.

    I must say you’ve done a very good job with this. In addition, the blog loads extremely fast for me on Opera.
    Outstanding Blog!

    Like

  2. I’ve been surfing online more than 2 hours today, yet I never found
    any interesting article likee yours. It is pretty worth enough for me.
    In my opinion, if all web owners and bloggers made
    good content as you did, the internet will be a lott more useful than ever before.|
    I couldn’t refrain from commenting. Perfectly written!|
    I will rigbt awayy grab your rss ffeed ass I can not in finding your e-mail
    subscription hyperlink orr e-newsletter service. Do yoou have any?

    Please permit me realize so that I may just subscribe.
    Thanks.|
    It’s appropriate time to make some plans for the future and it iss time too be happy.
    I have read this poszt and if I could I want to suggest
    you feww interesting things or tips. Perhaps you can wrte next articles
    referring too this article. I want to read more things
    aboout it!|
    It is perfect time too make a few plans for the future
    and it is time to be happy. I have read this publish and if I could
    I want to recommend you few fascinating issues or suggestions.

    Perhaps you coluld write nexct articles referring to this
    article. I wish to learn more issues about it!|
    I havee been browsing on-line more than threre hours
    as oof late, yet I never discobered any attention-grabbing
    article like yours. It is pretty price sufficient for me.
    In my view, iif all webmasters and bloggers made just riyht content material as you probably did, the web shall be
    a lot more helpful than ever before.|
    Ahaa, its good discussion on the topic of this post at this poace
    at this weblog, I have read all that, so at this
    time me also commenting here.|
    I am sure this post has touched alll the internet visitors, its really really fastidious paragraph on building up new blog.|
    Wow, this article is pleasant, my younger sister is analyzing such things,
    therefore I am going to let know her.|
    bookmarked!!, I like your site!|
    Way cool! Some extremely valid points! I appreciate you writing
    this write-up plus the rest of the website is also
    very good.|
    Hi, I do think this is a great blog. I stumbledupon it 😉
    I may revisit yet again since i have book marked it.
    Money aand fredom is the greatest way to change, may you be rich and continue to guide other people.|
    Woah! I’m really digging the template/theme of this website.

    It’s simple, yet effective. A lot of times it’s very difficult to get that “perfect balance” between user friendliness and appearance.
    I must say that you’ve done a excellent job with
    this. In addition, the blog loads very quick for me on Chrome.
    Excellent Blog!|
    Therse are really impressive ideas in on the
    topic of blogging. You have touched some pleasant things here.
    Any way keep up wrinting.|
    I like what you guys are up too. This type of clever work
    and exposure!Keepp up the excellent works guys I’ve added you guys to blogroll.|
    Hey there! Someone in my Facebook group shared this site with us
    soo I came to check it out. I’m definitely enjoying the
    information. I’m book-marking and will be twqeeting this to my followers!

    Superb blog and excellent design.|
    I enjoy what you guys tend to be upp too.
    Thhis kind of clever work and coverage! Keep up the fantastic works guys I’ve included you guys to blogroll.|
    Howdy would you mind stating whicdh blog platform you’re using?

    I’m going to start my own blog soon but I’m having a hard time making a decision between BlogEngine/Wordpress/B2evolution and Drupal.
    The reasson I ask is because your design and style seems different then most blogs and I’m looking
    for something unique. P.S Sorry ffor getting off-topic but I hadd to
    ask!|
    Hey there would you mind letting mee know whjich hosting company you’re
    working with? I’ve loaded your blog inn 3 different web browserrs and I must say this blog loads a lot quicker then most.
    Can you recommend a good hosting provider at a
    fair price? Kudos, I apprecjate it!|
    I like it when people get together and share thoughts. Great site,
    stick with it!|
    Thank you for the good writeup. It in fact was a amusement account it.
    Look advanced to ffar added agreeable from you!
    However, how cann we communicate?|
    Hi there just wanted to give you a quick heads up.

    The text in your content seem to be running off the screen in Safari.
    I’m not sure if this is a formatting issue or something to
    do wikth browser compatibility but I figured I’d post to let you
    know. The layout look great though! Hope you get thhe issue
    solved soon. Cheers|
    This iis a topic that is close to my heart… Many thanks! Exactly where
    are your contact details though?|
    It’s very easy to find out any matter on net as compared to textbooks, as I found this piece oof
    writing at this web page.|
    Does your blog have a contact page? I’m having trouble locating it but, I’d like to shoot yoou an email.
    I’ve got ome creative ideas for your blg you might be interested in hearing.

    Either way, great blog and I look forward to seeing it improve over time.|
    Hello! I’ve been reading your weblog for a while now and
    finally got the bravery to go ahead and give you a shout out from Atascocita Texas!
    Just wanted to say keep up the excelllent job!|
    Greetings from Los angeles! I’m bored to tears at work so I
    decided too browse your site on my iphone during lunch break.
    I enjoy thhe knowledge you provide here and can’t wait to taqke a look when I get home.
    I’m amazed at how fast your blog loaded on my cell phone ..
    I’m not even using WIFI, just 3G.. Anyways, great site!|
    Its like you read my mind! You seem to know a lot about this, such as yoou wrote the e-book in it or something.
    I believe that you simply cokuld do witrh some percent to power the mesage house a bit, but other than that, this is wonderful blog.

    A fantastic read. I’ll definitely bee back.|
    I visited many web sites buut the audio quality forr audio songs present at
    this web page is in fact wonderful.|
    Hi there, i read your blog from time too time and i own a similar one and i was juat wondering if
    you get a lot of spam comments? If so how do yoou stop
    it, any plugin or anything you can advise? I geet so much lately
    it’s driving me insane so any assistance is very much
    appreciated.|
    Greetings! Very useful advice in this particular article! It is the little changes that
    producxe the largest changes. Thanks a loot for sharing!|
    I truly love your site.. Very nice colors & theme. Didd yoou make this web site yourself?
    Please reply back as I’m wanting to create
    my very own site and would like to find out whete you got this from or what the theme is called.
    Thank you!|
    Hi there! This article could not be written any better!
    Reading through this article reminds me of mmy previous roommate!
    He continually kept talking about this. I’ll forward thhis post to him.
    Pretty sure he’ll hage a good read. Thank youu for sharing!|
    Whoa! This blog looks just like my old one! It’s on a entirely differdent topic but iit
    has pretty much the saje layout and design. Wondsrful choice off colors!|
    There’s definately a lott to learn about this issue. I like
    all of the points yyou made.|
    You’ve made some really good points there. I checked on the internet for more information about the issue and found most individuals will ggo aloong with
    your views on this website.|
    Hi, I read your new stuff daily. Your writing style
    iss awesome, keep up the good work!|
    I juset could not leave your website prior to suggesting that I actually ebjoyed the standarrd information an individual
    provide in your guests? Is going to be again often to inspect new posts|
    I need to to thank you for this wonderful read!!
    I absolutely loved every lirtle bit of it.
    I have got yyou bookmarked to lookk at neew things
    you post…|
    Hello, just wanted to tell you, I enjoyed this post.
    It was funny. Keep on posting!|
    Hi there, I enjoy reading through your article.
    I wanted to write a little comment to support you.|
    I every tijme spent my half an hpur to read this blog’s content everyday along woth a mug oof coffee.|
    I evedry time emailed this website post page too all my contacts, because if like to read it then mmy friends will too.|
    My developer is trying to convince mme to move to .net from PHP.
    I ave always disliked thee idea because of the expenses.
    But he’s tryiong none the less. I’ve been using Movable-type on numerous websitds ffor
    about a year and am worried about switching to another
    platform. I hav heard very good things about blogengine.net.

    Is there a way I can import all my wordpress posts into it?

    Any kind of help woiuld be greatly appreciated!|
    Hi there! I could have sworn I’ve visited this sikte before buut after lokoking at a few of
    the articles I realized it’s new to me. Nonetheless, I’m definitely delighted I
    stumbled upon it and I’ll be bookmarking it and checking back regularly!|
    Terrific work! Thaat is the kind of infomation that should be shared across tthe internet.
    Disgrace on Google for now not positioning this put up higher!
    Come on over and discuss wwith my site . Thanks =)|
    Heya i’m forr the first time here. I came across this board and I find It really useful & it helped me outt
    a lot. I hope to give something back and helop others like
    you helped me.|
    Hello there, There’s no doubt tat your blog could be having internet browser compatibility issues.

    Whenever I ake a look at your site in Safari, it looks fine however when opening in I.E., it’s got some overlapping issues.

    I jus wanted to provide you with a quick heds up! Other han that,
    wonderful site!|
    A person necessarily lend a hand to make severely posts I would state.
    This is thee very first time I frequented your web page and to
    this point? I amazed with the research you made to create thyis actual put upp incredible.
    Magnificent activity!|
    Heya i am for the first time here. I found this board and
    I to find It really useful & it helped me out much. I am hoping
    to offer one thing again and help others such as you helped me.|
    Hi! I just wish to offer you a biig thumbs up for the great info you have here on this post.
    I am returnjng to your blog for more soon.|
    I all the time used tto study piece of writing in news papers but now as I am a user
    of web therefore from noow Iamm using neet for content, thanks too web.|
    Youur waay off describing everything in this paragraph is really good,
    every one ccan easily know it, Thanks a lot.|
    Hello there, I found your boog bby means of Google even as looking
    for a related matter, your website got here up, it appears to be
    like great. I have bookmarked it in myy google bookmarks.

    Hi there, just was alert to your blog through Google, aand fouind that
    iit is really informative. I’m going tto be careful for
    brussels. I’ll be grateful if you continue this in future.
    Lots of folks will probably be benefited out
    of your writing. Cheers!|
    I am curious to find out what blog platform you’re utilizing?
    I’m experiencing some small security issues with my latest website and I’d llike tto find something more risk-free.

    Do you have any suggestions?|
    I’m extremely impressed with your writing skills as well as with the layout
    on your weblog. Is this a paid theme or did you customize itt yourself?
    Either way keep up the nice quality writing, it is rare to
    seee a nice blog like this one nowadays.|
    I’m really impressed together wth your writing talents as well as with the structure
    forr your blog. Is this a paid subject or
    did you modify it yourself? Either way keesp
    up the nice high quality writing, it’s uncommon to look a
    great blogg like this one nowadays..|
    Hello, Neat post. There iss an issue with your website in web explorer, woukd check this?
    IE still iis the market leader annd a good portion of
    people will leave out your fantastic writing due to this problem.|
    I amm nnot sure where you are getting your information, but great topic.
    I needs to spend some time learning muuch moree or understanding more.
    Thanks for magnificent info I was looking for this info for my mission.|
    Hello, i think that i saww you visited my web site thus i came to
    “return the favor”.I’m attempting to fund things to enhance my web site!I suppose its ook to use a few of your ide\

    Like

  3. Simply wish to say your article is as surprising. The clearness in your post is just nice and
    i can assume you are an expert on this subject.
    Well with your permission allow me to grab your RSS feed to keep up to date with
    forthcoming post. Thanks a million and please carry on the enjoyable work.

    Like

  4. Hi and thanks for the blog post i have been looking for this specific information on-line for a while
    now therefore appreciate it.

    Like

  5. My partner and I stumbled over here by a different web page and thought I may as well check things out.

    I like what I see so now i am following you. Look forward to exploring your web
    page repeatedly.

    Like

  6. This is really attention-grabbing, You’re a very skilled blogger. I’ve joined your rss feed and look forward to looking for more of your great post. Additionally, I’ve shared your website in my social networks!

    Like

  7. I think that everything posted was actually very reasonable.
    However, consider this, suppose you added a little information? I mean,
    I don’t wish to tell you how to run your website, however what if you added a post
    title that grabbed people’s attention? I mean How to configure static
    routing on cisco router using serial port? | Technohelper24 is a
    little vanilla. You could look at Yahoo’s front page and see
    how they create article titles to get people to click.
    You might add a video or a related pic or two to
    get people interested about what you’ve written. Just my opinion,
    it would make your posts a little livelier.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s