Learn how to configure static routing on 4 routers?


In the previous article of static routing, we have learned the simple static routing on routing. Now in this lab, we learn about how to configure static routing on 4 routers by this article you learn about how to configure static routing on many routers as you wish. We have one another lab here to learn static routing perfectly. By learning CCNA you find a job in the company and earn money from that place. So let’s start routing from a lab in cisco packet tracer.

Static routing

Follow given below steps and codes to configure static routing on the router and repeat it on for more than 4 routers also.

For router r1 type given below codes for up all ports of routers and assign IP address on interfaces of the router.

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname r1

r1(config)#

r1(config)#interface FastEthernet0/0

r1(config-if)#ip address 1.0.0.1 255.0.0.0

r1(config-if)#no shutdown

r1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

r1(config-if)#exit

r1(config)#interface FastEthernet0/1

r1(config-if)#ip address 4.0.0.2 255.0.0.0

r1(config-if)#no shutdown

r1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

r1(config-if)#exit

r1(config)#interface Ethernet0/0/0

r1(config-if)#ip address 5.0.0.1 255.0.0.0

r1(config-if)#no shutdown

r1(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

r1(config-if)#exit

For router r2 type given below codes for up all ports of routers and assign ip address on interfaces of router.

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname r2

r2(config)#

r2(config)#interface FastEthernet0/0

r2(config-if)#ip address 1.0.0.2 255.0.0.0

r2(config-if)#no shutdown

r2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

r2(config-if)#exit

r2(config)#interface FastEthernet0/1

r2(config-if)#ip address 2.0.0.1 255.0.0.0

r2(config-if)#no shutdown

r2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

r2(config-if)#exit

r2(config)#interface Ethernet0/0/0

r2(config-if)#ip address 6.0.0.1 255.0.0.0

r2(config-if)#no shutdown

r2(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

r2(config-if)#exit

For router r3 type given below codes for up all ports of routers and assign ip address on interfaces of router.

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname r3

r3(config)#

r3(config)#interface FastEthernet0/0

r3(config-if)#ip address 3.0.0.1 255.0.0.0

r3(config-if)#no shutdown

r3(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

r3(config-if)#exit

r3(config)#interface FastEthernet0/1

r3(config-if)#ip address 2.0.0.2 255.0.0.0

r3(config-if)#no shutdown

r3(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

r3(config-if)#exit

r3(config)#interface Ethernet0/0/0

r3(config-if)#ip address 7.0.0.1 255.0.0.0

r3(config-if)#no shutdown

r3(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

r3(config-if)#exit

For router r4 type given below codes for up all ports of routers and assign ip address on interfaces of router.

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname r4

r4(config)#interface FastEthernet0/0

r4(config-if)#ip address 4.0.0.1 255.0.0.0

r4(config-if)#no shutdown

r4(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

r4(config-if)#exit

r4(config)#interface FastEthernet0/1

r4(config-if)#ip address 3.0.0.2 255.0.0.0

r4(config-if)#no shutdown

r4(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

r4(config-if)#exit

r4(config)#interface Ethernet0/0/0

r4(config-if)#ip address 8.0.0.1 255.0.0.0

r4(config-if)#no shutdown

r4(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

r4(config-if)#exit

r4(config)#

Now all ports are up of all 4 routers and ip will be assigned on all interfaces of all routers.

If you don’t know about basics of static routing read my previous article on static routing

How to configure basic static routing on routers

Now configure static routing on all routers by following given below steps

For router r1 type given below codes to configure static routing

r1(config)#ip route 2.0.0.0 255.0.0.0 1.0.0.2

r1(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2

r1(config)#ip route 6.0.0.0 255.0.0.0 1.0.0.2

r1(config)#ip route 7.0.0.0 255.0.0.0 2.0.0.2

r1(config)#ip route 8.0.0.0 255.0.0.0 4.0.0.1

For router r2 type given below codes to configure static routing

r2(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2

r2(config)#ip route 4.0.0.0 255.0.0.0 1.0.0.1

r2(config)#ip route 5.0.0.0 255.0.0.0 1.0.0.1

r2(config)#ip route 7.0.0.0 255.0.0.0 2.0.0.2

r2(config)#ip route 8.0.0.0 255.0.0.0 3.0.0.2

For router r3 type given below codes to configure static routing

r3(config)#ip route 6.0.0.0 255.0.0.0 2.0.0.1

r3(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1

r3(config)#ip route 4.0.0.0 255.0.0.0 3.0.0.2

r3(config)#ip route 5.0.0.0 255.0.0.0 1.0.0.1

r3(config)#ip route 8.0.0.0 255.0.0.0 3.0.0.2

For router r4 type given below codes to configure static routing

r4(config)#ip route 1.0.0.0 255.0.0.0 4.0.0.2

r4(config)#ip route 5.0.0.0 255.0.0.0 4.0.0.2

r4(config)#ip route 6.0.0.0 255.0.0.0 1.0.0.2

r4(config)#ip route 2.0.0.0 255.0.0.0 3.0.0.1

r4(config)#ip route 7.0.0.0 255.0.0.0 3.0.0.1

Now your routers will be configured  by static routing on it  check it by communicating two pc with each other

Now communicate pc0 to pc3 and results and codes will be shown here below

Now type codes in command prompt of pc0 results will be shown here.

PC>ping 6.0.0.2

Pinging 6.0.0.2 with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Ping statistics for 6.0.0.2:

Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

PC>ping 6.0.0.2

Pinging 6.0.0.2 with 32 bytes of data:

Request timed out.

Reply from 6.0.0.2: bytes=32 time=1ms TTL=125

Reply from 6.0.0.2: bytes=32 time=0ms TTL=125

Reply from 6.0.0.2: bytes=32 time=0ms TTL=125

Ping statistics for 6.0.0.2:

Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 1ms, Average = 0ms

If these results are shown on your screen your routing will be configured perfectly.

THAT’S IT

If you have any queries regarding this feel free to ask using the comment section and also provide feedback through the comment section because your feedback is valuable for us.

One thought on “Learn how to configure static routing on 4 routers?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s